Turnitin unavailable
Incident Report for Macquarie University IT
Resolved
Access to Turnitin is fully restored and all services are operational.

Resolution Description: Turnitin have reported that the service is restored.

Services Affected: Turnitin
Impact: Staff and Students

Thank you for your patience during this service disruption.

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted 8 days ago. Oct 10, 2017 - 10:44 AEDT
Investigating
Turnitin is currently unavailable.

We are investigating and we apologise for any inconvenience caused.

Services Affected: Turnitin
Impact: Staff and Students

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted 8 days ago. Oct 10, 2017 - 10:26 AEDT
This incident affected: Student systems and services (click to expand) (Turnitin).