Turnitin intermittent access
Incident Report for Macquarie University IT
Resolved
This incident has been resolved.
Posted 7 months ago. Oct 06, 2016 - 22:40 AEDT
Investigating
Turnitin is currently experiencing intermittent access.

We are investigating and apologise for any inconvenience caused.

Services Affected: Turnitin
Impact: Staff/Students

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted 7 months ago. Oct 06, 2016 - 22:24 AEDT
This incident affected: Student systems and services (click to expand) (Turnitin).