Turnitin Service Alert
Incident Report for Macquarie University IT
Resolved
You may have experienced issues with uploading and viewing submissions today. This was the result of a service degradation affecting the performance of Turnitin's Feedback Studio.

When did this happen?

PST August 28th 6:15pm - 9:15 PST

Turnitin has announced that this has now been resolved.

We sincerely apologize for the inconvenience caused.

Turnitin engineers continue to monitor the system.

Thanks for your patience!
Posted 21 days ago. Aug 29, 2018 - 15:13 AEST
Investigating
We are experiencing intermittent issues with our Turnitin services.

Turnitin team and engineers are working to fix the issue as soon as possible.

We will be providing updates to you as things progress.

Apologies for inconvenience.

OneHelp Reference: INC0070185
Posted 21 days ago. Aug 29, 2018 - 12:10 AEST
This incident affected: Student systems and services (click to expand) (Turnitin) and iLearn.