Power outage affecting multiple buildings across campus
Incident Report for Macquarie University IT
Resolved
The power issue has been repaired.

Thank you for your patience during this service disruption.

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted 5 months ago. May 10, 2019 - 13:05 AEST
Investigating
There is currently a power outage affecting multiple buildings across campus.

Library building has been evacuated.

Student Lab in 17 Wally's Walk is closed.

IT Service Desk has been temporary relocated to MUSE building just outside Student Connect and we can still be contacted via phones and email.

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted 5 months ago. May 10, 2019 - 09:54 AEST