Turnitin intermittent access
Incident Report for Macquarie University IT
Resolved
This incident has been resolved.
Posted about 1 year ago. Dec 13, 2016 - 11:58 AEDT
Investigating
Turnitin is currently experiencing intermittent access.

We are investigating and apologise for any inconvenience caused.

Services Affected: Turnitin
Impact: Staff and Students

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted about 1 year ago. Dec 13, 2016 - 11:38 AEDT
This incident affected: Student systems and services (click to expand) (Turnitin).