Turnitin unavailable
Incident Report for Macquarie University IT
Resolved
This incident has been resolved.
Posted 9 months ago. Jul 21, 2016 - 15:03 AEST
Investigating
Turnitin is currently unavailable.

We have contacted Turnitin about this issue and are awaiting an ETA on when the service will be restored.

We are working to resolve this and apologise for any inconvenience caused.

Services Affected: Turnitin
Impact: Staff and Students

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted 9 months ago. Jul 21, 2016 - 13:04 AEST