Turnitin unavailable
Incident Report for Macquarie University IT
Resolved
Access to Turnitin is fully restored and all services are operational.

OneHelp Reference Number: INC0083807
Services Affected: Turnitin
Impact: Staff/Students

Thank you for your patience during this service disruption.

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted 2 months ago. Apr 09, 2019 - 09:25 AEST
Investigating
Turnitin is currently experiencing service issues.

Vendor is currently investigating and we apologise for any inconvenience caused.

OneHelp Reference Number: INC0083766
Services Affected: Turnitin
Impact: Staff and Students

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted 2 months ago. Apr 08, 2019 - 13:53 AEST
This incident affected: Student systems and services (click to expand) (Turnitin).