Turnitin intermittent access
Incident Report for Macquarie University IT
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 18, 2018 - 09:14 AEST
Investigating
Turnitin is currently experiencing intermittent access.

We are investigating and apologise for any inconvenience caused.

Services Affected: iLearn/Turnitin
Impact: Staff and students

For more information please contact the IT Service Desk on 02 9850 HELP (4357) Opt 2, or email onehelp@mq.edu.au
Posted 3 months ago. Sep 17, 2018 - 10:55 AEST
This incident affected: Student systems and services (click to expand) (Turnitin).