Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 08, 2026 - 20:30 AEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 08, 2026 - 17:31 AEST
Scheduled
Scheduled maintenance is taking place on iTeach and Unit Guides on 8 September, 2026 from 8:30pm to 11:30pm..
As a result, iTeach and Unit Guides may experience reduced performance or brief intermittent access during this time.
To facilitate this maintenance, access to iTeach and Unit Guides may be impacted. The services are expected to remain available, but users may experience increased latency and a brief interruption of up to two minutes.
Stay informed:
- Keep up-to-date on the operational status of all IT systems and services by subscribing to real-time notifications at Macquarie University IT Status - Follow @mqu_it on X for breaking alerts and status updates - Contact the IT Service Desk on 02 9850 HELP (4357), or email onehelp@mq.edu.au.
Posted Sep 08, 2026 - 16:06 AEST
This scheduled maintenance affects: Staff systems and services (click to expand) (iTeach) and Student systems and services (click to expand) (Unit Guides).