Talent, Timesheets, Invoices, My Library, Multisearch & Alma Unavailable
Incident Report for Macquarie University IT
Resolved
All applications have been restored, root cause analysis is currently in progress.
Posted 12 months ago. Apr 04, 2016 - 10:00 AEDT
Investigating
Talent, Timesheets, Invoices, My Library Multisearch & Alma are currently unavailable.

We are investigating and apologize for any inconvenience caused.

OneHelp Reference Number: INC0019719
Services Affected: Talent, Timesheets, Invoices, My Library, Multisearch & Alma
Impact: Staff/Students
Posted 12 months ago. Apr 03, 2016 - 11:41 AEDT