iPrint limited service
Incident Report for Macquarie University IT
Resolved
This incident has been resolved.
Posted almost 3 years ago. Mar 11, 2015 - 18:08 AEDT
Investigating
iPrint is experiencing reduced printing performance. Currently investigating.
Posted almost 3 years ago. Mar 11, 2015 - 12:46 AEDT