Workday unavailable
Incident Report for Macquarie University IT
Resolved
Workday maintenance has concluded and the web site is now accessible.
Posted Jul 18, 2021 - 11:30 AEST
Identified
Workday is currently performing system maintenance and will be unavailable between 4:00 PM, Saturday 17th July and 4:00 AM, Sunday 18th July.
Posted Jul 17, 2021 - 17:15 AEST
This incident affected: Staff systems and services (click to expand) (Workday).