Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 26, 2026 - 20:30 AEST
Update
We will be undergoing scheduled maintenance during this time.
Posted May 26, 2026 - 16:32 AEST
Scheduled
Scheduled maintenance is taking place on iTeach and Unit Guides on 26th May, 2026 from 8:30pm to 11:30pm.
As a result, iTeach and Unit Guides may be partially unavailable during this time and service may be degraded.
Stay informed: - Keep up-to-date on the operational status of all IT systems and services by subscribing to real-time notifications at https://itstatus.mq.edu.au - Follow @mqu_it on X for breaking alerts and status updates - Contact the IT Service Desk on 02 9850 HELP (4357), or email onehelp@mq.edu.au.
Posted May 22, 2026 - 17:24 AEST
This scheduled maintenance affected: Staff systems and services (click to expand) (iTeach) and Student systems and services (click to expand) (Unit Guides).